archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-websocket-client / repos / community-any / PKGBUILD
blobb0d24969a630c3940d4334bb7f9e1e609014a30d
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Thore Bödecker <foxxx0@archlinux.org>
3 # Contributor: Matmas <matmas@matmas.net>
4 # Contributor: Thomas Gubler <thomasgubler@gmail.com>
5 # Contributor: Daniel YC Lin <dlin.tw at gmail>
6 # Contributor: Florian Bruhin <archlinux.org@the-compiler.org>
8 pkgname=python-websocket-client
9 pkgver=1.5.1
10 pkgrel=2
11 pkgdesc="WebSocket client library for Python"
12 arch=('any')
13 url="https://github.com/websocket-client/websocket-client"
14 license=('LGPL')
15 depends=('python')
16 makedepends=('python-setuptools')
17 checkdepends=('python-pytest')
18 source=("https://pypi.io/packages/source/w/websocket-client/websocket-client-$pkgver.tar.gz")
19 sha512sums=('9fce0c8de64e051b151c40a295a7f722ed7f95d19bd92ffd5cd9c64962821024e79b70d18ca7e30ca8b8707ba86be041134f13d7e2cf7bc4a4539eb22ba60895')
21 build() {
22   cd websocket-client-$pkgver
23   python setup.py build
26 check() {
27   cd websocket-client-$pkgver
28   pytest
31 package() {
32   cd websocket-client-$pkgver
33   python setup.py install --root="$pkgdir" --optimize=1
34   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
37 # vim:set ts=2 sw=2 ft=sh et: