1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
6 pkgdesc="A fast and modern Python SOAP client"
9 url="https://docs.python-zeep.org"
10 depends=('python-attrs' 'python-isodate' 'python-lxml' 'python-platformdirs' 'python-requests'
11 'python-requests-toolbelt' 'python-requests-file' 'python-pytz')
12 makedepends=('python-setuptools')
13 checkdepends=('python-pytest' 'python-freezegun' 'python-pretend' 'python-pytest-cov'
14 'python-requests-mock' 'python-pytest-httpx' 'python-pytest-asyncio' 'python-aiohttp'
15 'python-aioresponses' 'python-xmlsec')
16 source=("https://github.com/mvantellingen/python-zeep/archive/$pkgver/$pkgname-$pkgver.tar.gz")
17 sha512sums=('e708fcba7330088f7feee0d4ae64fa5480dcdff433e1a450f16ba90682b46fb9f0a335e96327dc70fe98e543697968609059bfac3bbd2f689d22ff51df95510f')
20 sed -i -e 's/==/>=/' -e '/flake8/d' -e '/isort/d' python-zeep-$pkgver/setup.py
24 cd python-zeep-$pkgver
29 cd python-zeep-$pkgver
30 PYTHONPATH="$PWD"/build/lib pytest
34 cd python-zeep-$pkgver
35 python setup.py install --root="$pkgdir" --optimize=1
36 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/