archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-zeroconf / trunk / PKGBUILD
blob73cfa497b2fcdea3ab10b70d0d99aa8fbc8c2c4e
1 # Maintainer: Jelle van der Waa <jelle@archlinux.org>
2 # Contributor: Maxim Andersson <thesilentboatman@gmail.com>
4 pkgname=python-zeroconf
5 pkgver=0.39.4
6 pkgrel=2
7 pkgdesc="A pure python implementation of multicast DNS service discovery"
8 arch=('any')
9 url="https://github.com/jstasiak/python-zeroconf"
10 license=('LGPL')
11 depends=('python' 'python-netifaces' 'python-six' 'python-ifaddr' 'python-async-timeout')
12 makedepends=('python-setuptools')
13 checkdepends=('python-pytest')
14 source=($pkgname-$pkgver.tar.gz::https://github.com/jstasiak/${pkgname}/archive/${pkgver}.tar.gz)
15 sha256sums=('32783c9a583419abe7223ba199e2ddebe9533011caecf6a268852e0fbea1186a')
17 build() {
18   cd "${pkgbase}-${pkgver}"
19   python3 setup.py build
22 package() {
23   cd "${pkgbase}-${pkgver}"
25   python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
28 check() {
29   cd "${pkgbase}-${pkgver}"
30   pytest -k 'not test_integration_with_listener_ipv6' tests
33 # vim:set ts=2 sw=2 et: