1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
6 pkgdesc="Render MathML and LaTeX Math to SVG without Latex installation"
7 url="https://ziamath.readthedocs.io/"
10 depends=('python-ziafont')
11 optdepends=('python-latex2mathml: for latex support')
12 makedepends=('python-setuptools')
13 checkdepends=('python-latex2mathml' 'python-nbval' 'python-pytest-runner')
14 source=("$pkgname-$pkgver.tar.gz::https://bitbucket.org/cdelker/ziamath/get/$pkgver.tar.bz2")
15 sha512sums=('ff7b46fa5485bdf053a128da5acb9e973391eb3528b03251ddaa3574726821f8b38892a8d412e3a2f05aa95558e2ee8f1f07fb43fc89602677d398db26419732')
18 mv cdelker-ziamath-* ziamath-$pkgver
28 python setup.py pytest --addopts --nbval || echo "Tests failed"
33 python setup.py install --root="$pkgdir" --optimize=1
35 install -Dm644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname/