1 # Maintainer: Aaron Griffin <aaron@archlinux.org>
2 # Contributor: Federico Quagliata (quaqo) <quaqo@despammed.com>
3 # Contributor: cdhotfire <cdhotfire@gmail.com>
6 pkgname=('python-eyed3')
10 pkgdesc="A Python module and program for processing information about mp3 files"
12 url="http://eyed3.nicfit.net/"
14 depends=('python-deprecation' 'python-filetype' 'python-packaging')
15 checkdepends=('python-factory-boy' 'python-pytest')
16 source=(https://files.pythonhosted.org/packages/source/e/eyeD3/eyeD3-$pkgver.tar.gz
17 http://eyed3.nicfit.net/releases/eyeD3-test-data.tgz)
18 sha256sums=('4b5064ec0fb3999294cca0020d4a27ffe4f29149e8292fdf7b2de9b9cabb7518'
19 '8bd11c921e0e34f88b84f1a51e24290d0243f3b2660233a527902f2c13af3a67')
30 ln -s "$srcdir"/eyeD3-test-data.tgz tests/
32 # Skipping display plugin tests because grako is not packaged, and abandoned upstream
33 python -m pytest --deselect tests/test_display_plugin.py
36 package_python-eyed3() {
38 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build