1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Eli Schwartz <eschwartz@archlinux.org>
3 # Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
4 # Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
5 # Contributor: Jkkyll Wu <adaptee at gmail [dot] com>
6 # Contributor: Thomas Dziedzic < gostrc at gmail >
7 # Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
8 # Contributor: Geoffroy Carrier <geoffroy.carrier@koon.fr>
11 pkgname=(qbittorrent qbittorrent-nox)
15 url='https://www.qbittorrent.org'
17 depends=(libtorrent-rasterbar qt6-base)
18 makedepends=(cmake boost qt6-tools qt6-svg)
19 optdepends=('python: needed for torrent search tab')
20 source=(https://downloads.sourceforge.net/sourceforge/qbittorrent/${pkgname}-${pkgver}.tar.xz{,.asc})
21 sha256sums=('109ecff22cb80f1e3ee5b7d3d2d34537839c15f75030632ef131d92b047f4e05'
23 validpgpkeys=('D8F3DA77AAC6741053599C136E4A2D025B7CC9A2') # sledgehammer999 <sledgehammer999@qbittorrent.org>
26 cmake -B build -S $pkgbase-$pkgver \
27 -DCMAKE_INSTALL_PREFIX=/usr \
31 cmake -B build-nox -S $pkgbase-$pkgver \
32 -DCMAKE_INSTALL_PREFIX=/usr \
36 cmake --build build-nox
39 package_qbittorrent() {
40 pkgdesc='An advanced BitTorrent client programmed in C++, based on Qt toolkit and libtorrent-rasterbar'
41 depends+=(qt6-svg hicolor-icon-theme)
43 DESTDIR="$pkgdir" cmake --install build
44 install -Dm644 $pkgbase-$pkgver/COPYING -t "$pkgdir"/usr/share/licenses/$pkgname
47 package_qbittorrent-nox() {
48 pkgdesc='An advanced BitTorrent client programmed in C++, based on Qt toolkit and libtorrent-rasterbar, w/o gui'
50 DESTDIR="$pkgdir" cmake --install build-nox
51 install -Dm644 $pkgbase-$pkgver/COPYING -t "$pkgdir"/usr/share/licenses/$pkgname