archrelease: copy trunk to community-any
[ArchLinux/community.git] / qd / trunk / PKGBUILD
blob66b050a7a5a7d872522812db392c080e50ce7f25
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: eolianoe <eolianoe At GoogleMAIL DoT CoM>
3 # Contributor: Xyne <ca dot archlinux at xyne, backwards>
5 pkgname=qd
6 pkgver=2.3.23
7 pkgrel=1
8 pkgdesc='C++/Fortran-90 double-double and quad-double library'
9 arch=(x86_64)
10 url='https://crd-legacy.lbl.gov/~dhbailey/mpdist'
11 license=(BSD)
12 makedepends=(gcc-fortran)
13 source=(https://crd-legacy.lbl.gov/~dhbailey/mpdist/$pkgname-$pkgver.tar.gz)
14 sha256sums=('b3eaf41ce413ec08f348ee73e606bd3ff9203e411c377c3c0467f89acf69ee26')
16 build() {
17   cd $pkgname-$pkgver
19   export FC=gfortran
20   ./configure --prefix=/usr --enable-shared
21   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
22   make
25 check() {
26   cd $pkgname-$pkgver
28   make check
31 package() {
32   cd $pkgname-$pkgver
34   make DESTDIR="$pkgdir" install
35   install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING