archrelease: copy trunk to community-any
[ArchLinux/community.git] / reapack / trunk / PKGBUILD
blob0068d0448630beb403ef63383cf695364eff595d
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
3 pkgname=reapack
4 pkgver=1.2.4.2
5 pkgrel=3
6 pkgdesc='Package manager for the Reaper DAW'
7 arch=('x86_64')
8 url='https://reapack.com'
9 license=('GPL3' 'LGPL3')
10 depends=(
11   'reaper'
12   'libxml2'
13   'curl'
14   'sqlite'
16 makedepends=(
17   'git'
18   'cmake'
19   'boost'
20   'openssl'
21   'zlib'
22   'ruby'
23   'php'
24   'catch2'
26 install='reapack.install'
27 _commit='daa3346cee146d5eeca806452d26b70e623d5aa7'
28 source=(
29   "$pkgname::git+https://github.com/cfillion/reapack#commit=$_commit"
30   'github.com-justinfrankel-wdl::git+https://github.com/justinfrankel/WDL'
31   'github.com-justinfrankel-reaper-sdk::git+https://github.com/justinfrankel/reaper-sdk'
33 b2sums=('SKIP'
34         'SKIP'
35         'SKIP')
37 pkgver() {
38   cd "$pkgname"
40   git describe --tags | sed 's/^v//'
43 prepare() {
44   cd "$pkgname"
46   # prepare git submodule(s)
47   git submodule init
48   git config submodule.vendor/WDL.url "$srcdir/github.com-justinfrankel-wdl"
49   git config submodule.vendor/reaper-sdk.url "$srcdir/github.com-justinfrankel-reaper-sdk"
50   git -c protocol.file.allow=always submodule update
52   # FTBFS due to catch2 v3 not being in the repos yet
53   # so we have to use an older version
54   git revert --no-commit d551e255fe79ea1e463fe757554a55bf5adf5058
56   # FTBFS: FS#77178
57   git cherry-pick --no-commit f2806c95ba16549e969581429d1fc51616c68796
60 build() {
61   cd "$pkgname"
63   cmake \
64     -B build \
65     -DCMAKE_BUILD_TYPE=Release
67   cmake --build build
70 check() {
71   make -C "$pkgname/build" test
74 package() {
75   cd "$pkgname"
77   # plugin
78   install -vDm755 -t "$pkgdir/usr/lib/$pkgname" "build/reaper_reapack-$CARCH.so"
80   # documentation
81   install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md