1 # Maintainer: Andrew Crerar <crerar@archlinux.org>
2 # Maintainer: Frederik Schwan <freswa at archlinux dot org>
3 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
4 # Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
5 # Contributor: Jan-Erik Rediger <badboy at archlinux dot us>
6 # Contributor: nofxx <x@<nick>.com>
11 pkgdesc='An in-memory database that persists on disk'
13 url='https://redis.io/'
15 depends=('jemalloc' 'grep' 'shadow' 'systemd-libs')
16 # pkg-config fails to detect systemd libraries if systemd is not installed
17 makedepends=('systemd' 'openssl')
18 backup=('etc/redis/redis.conf'
19 'etc/redis/sentinel.conf')
21 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/redis/redis/archive/${pkgver}.tar.gz"
23 redis-sentinel.service
26 redis.conf-sane-defaults.patch
27 redis-5.0-use-system-jemalloc.patch)
28 sha512sums=('603efa12c98163a2abe6874715362c7251c789dad2bff678f4a500e56d1ee3fdcc641e4b635395f7c6a7cefdff073f1eddba5258c99e8f128307f9532949e673'
29 '8abf27f173a4532295dafd91b8e6e226e4376f1b2543c911e4fa60466d50523ada4dcfe520a738fd756c5725f4319153a0c0b26f6cdba234775114c72e4e7865'
30 '2314c26920f5f0989fb98622f594b621a0b5035525146263da3fdfe640257118e03fc1903c15a62bcd4fbf260e0dcbf9249088292323739a607a11c9630795bf'
31 '2227dfb41bf5112f91716f011862ba5fade220aea3b6a8134a5a05ee3af6d1cca05b08d793a486be97df98780bf43ac5dc4e5e9989ae0c5cd4e1eedb6cee5d71'
32 '149e56c5da953e61d2f3864949c38d3f36d2ab1af6c74571ae36fa9ec991dee93dcac81e3caff69ac581a5218405f3e896b5dc58b9474f997bff48f5af06ee68'
33 'f45b5d20769159faeeb705e1bb9e4fdc3d74c0779b476cada829bfb49014c6ba6cd78d1d2751bf39acb6db4528281e9cab3aca684cadf687eb5fad10c7453154'
34 '0acb08a6e0eaba239db7461bcfeddfbe0c1aaa517dc33c3918c9e991a1d5067cfe135b7f75085caade8c3ababd51ec9cefcc4120f57818bea1f7029a548a7732')
38 patch -Np1 < ../redis.conf-sane-defaults.patch
39 patch -Np1 < ../redis-5.0-use-system-jemalloc.patch
50 make PREFIX="$pkgdir"/usr install
52 install -Dm644 COPYING "$pkgdir"/usr/share/licenses/redis/LICENSE
53 install -Dm644 -t "$pkgdir"/etc/redis redis.conf sentinel.conf
54 install -Dm644 -t "$pkgdir"/usr/lib/systemd/system/ ../redis.service ../redis-sentinel.service
55 install -Dm644 "$srcdir"/redis.sysusers "$pkgdir"/usr/lib/sysusers.d/redis.conf
56 install -Dm644 "$srcdir"/redis.tmpfiles "$pkgdir"/usr/lib/tmpfiles.d/redis.conf