archrelease: copy trunk to community-any
[ArchLinux/community.git] / repod / trunk / PKGBUILD
blob3bab820ae9fb6162e11fa02fb528a47772e0d806
1 # Maintainer: David Runge <dvzrv@archlinux.org>
3 pkgname=repod
4 pkgver=0.2.2
5 pkgrel=2
6 pkgdesc="Tooling to maintain binary package repositories"
7 arch=(any)
8 url="https://repod.archlinux.page/"
9 license=(GPL3)
10 depends=(
11   pyalpm
12   python-aiofiles
13   python-email-validator
14   python-jinja
15   python-magic
16   python-orjson
17   python-pydantic
18   python-pyxdg
19   python-pyzstd
20   python-subprocess-tee
21   python-tomli
23 makedepends=(
24   just
25   python-build
26   python-installer
27   python-poetry-core
28   python-setuptools
29   python-sphinx
30   python-sphinx-argparse
31   python-sphinxcontrib-programoutput
32   python-wheel
34 checkdepends=(python-pytest python-pytest-asyncio python-pytest-lazy-fixture)
35 source=(
36   https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz
38 sha256sums=('0d30e17f27402044aaa875b476b81c85f400cf634c543d34bb61d20bf47bc84d')
39 b2sums=('e4bee6a48b905e5d58353ec2ce47d01216c35f1c6195d2fae8822a56c6cd49d6b4ae80a0054d9b83679036ffa066573bae114dc24e71177fb2da334cd474f7f7')
41 build() {
42   cd $pkgname-$pkgver
43   just build
46 check() {
47   cd $pkgname-$pkgver
48   just check
51 package() {
52   cd $pkgname-$pkgver
53   just --set destdir "$pkgdir" install