1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
6 pkgdesc='JWK, JWKS, JWS, JWE and JWT C library'
8 url=https://github.com/babelouest/rhonabwy
28 provides=(librhonabwy.so)
29 _tag=393fc0781826d63f0e0e090ab18dcb18bd8f2f5e
30 source=(git+https://github.com/babelouest/rhonabwy.git#tag=${_tag})
31 validpgpkeys=(8405B02FCC28EF9744C8F253FE82139440BD22B9) # Nicolas Mora <nicolas@babelouest.org>
36 git describe --tags | sed 's/^v//'
40 export CFLAGS+=" -Wno-maybe-uninitialized -Wno-error=attribute-warning"
41 cmake -S rhonabwy -B build -G Ninja \
42 -DCMAKE_BUILD_TYPE=None \
43 -DCMAKE_INSTALL_PREFIX=/usr \
44 -DBUILD_RHONABWY_DOCUMENTATION=ON
49 DESTDIR="${pkgdir}" ninja -C build install
50 install -dm 755 "${pkgdir}"/usr/share/doc/rhonabwy
51 cp -dr --no-preserve=ownership rhonabwy/doc/html "${pkgdir}"/usr/share/doc/rhonabwy/