1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=ruby-certificate_authority
6 pkgdesc='Ruby gem for managing the core functions outlined in RFC-3280 for PKI'
8 url='https://github.com/cchandler/certificate_authority'
11 makedepends=(ruby-pry ruby-rake ruby-rspec)
13 source=(https://github.com/cchandler/certificate_authority/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
14 sha256sums=('b6cc0d136d8f7ebdaa796c62e7eb8e755f2e409616c55990a8bde6f255154890')
17 cd certificate_authority-$pkgver
18 sed -e '/[cC]overalls/d' -e '/rubocop/d' -r -e 's|git ls-files -z|find . -type f -not -path "*/\.git/*" -printf "%P\\\\0"|' \
19 -i certificate_authority.gemspec Rakefile spec/spec_helper.rb
24 local _gemdir="$(gem env gemdir)"
25 cd certificate_authority-$pkgver
30 --ignore-dependencies \
32 --install-dir "tmp_install/$_gemdir" \
33 --bindir "tmp_install/usr/bin" \
34 pkg/certificate_authority-$pkgver.gem
35 find "tmp_install/$_gemdir/gems/" \
42 -iname "gem.build_complete" -o \
46 rm -r tmp_install/$_gemdir/cache
50 local _gemdir="$(gem env gemdir)"
51 cd certificate_authority-$pkgver
52 GEM_HOME="tmp_install/$_gemdir" rake spec
56 cd certificate_authority-$pkgver
57 cp -a tmp_install/* "$pkgdir"/