1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
4 pkgname=(python-rzpipe)
7 pkgdesc='Access rizin via pipe from any programming language'
8 url='https://github.com/rizinorg/rz-pipe'
11 makedepends=('python' 'python-setuptools' 'rizin')
12 source=(${url}/archive/python-v${pkgver}/${pkgname}-${pkgver}.tar.gz)
13 sha512sums=('831fdb764f97137764eee50ce4dcec01f06a9ee456e6066bc44bd78fd4178781ac3aa160c6290584b63403a7ea67c4d3ad850661a6466c196d2db2463e91734f')
14 b2sums=('7aa451a8d04216d86a7f5515c5146b34f689a8e0efcb0975792839f86eca315fc4bc1bfc8ea8736cbdcc3c040bbbcbc080183cbaf38ea0fb89056d3154317969')
17 cd rz-pipe-python-v${pkgver}/python
21 package_python-rzpipe() {
22 depends=('python' 'rizin')
23 cd rz-pipe-python-v${pkgver}/python
24 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
25 install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
26 install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"