1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Chocobo1 <chocobo1@archlinux.net>
3 # Contributor: Jean Lucas <jean@4ray.co>
8 pkgdesc='Shared compilation cache'
10 url=https://github.com/mozilla/sccache
24 'memcached: Memcached support'
25 'redis: Redis support'
27 _tag=844da898992f8e2a755d0965adab743648261e51
28 source=(git+https://github.com/mozilla/sccache.git#tag=${_tag})
33 git describe --tags | sed 's/^v//'
39 --manifest-path sccache/Cargo.toml
43 export CFLAGS+=' -ffat-lto-objects'
44 export LDFLAGS+=' -lzstd'
48 --manifest-path sccache/Cargo.toml \
50 --features native-zlib
57 # --manifest-path sccache/Cargo.toml \
59 # --features native-zlib
63 export CFLAGS+=' -ffat-lto-objects'
64 export LDFLAGS+=' -lzstd'
70 --root "${pkgdir}"/usr \
72 --features native-zlib