archrelease: copy trunk to community-any
[ArchLinux/community.git] / scummvm-tools / trunk / PKGBUILD
blobe05aa7d87792107e765da7961c7577c7866f6889
1 # Maintainer: Sven-Hendrik Haase <svenstaro@archlinux.org>
2 # Contributor: Jérémie Dimino <jeremie@dimino.org>
3 # Contributor: Sebastian Hase <sebastian_hase@gmx.de>
4 # Contributor: Joe Davison <joe@thosedamnpeanuts.com>
5 pkgname=scummvm-tools
6 pkgver=2.7.0
7 pkgrel=1
8 pkgdesc="A set of tools that enable you to convert, compress and decode game datafiles for ScummVM"
9 url="http://www.scummvm.org/"
10 license=('GPL')
11 depends=('libpng' 'wxwidgets-gtk3' 'flac' 'libvorbis')
12 arch=('x86_64')
13 source=("https://www.scummvm.org/frs/scummvm-tools/${pkgver}/scummvm-tools-${pkgver}.tar.xz")
14 sha512sums=('0f6541f86814a089b10969e8e0cc8c985ac4d3b5f15daf91869a9b9cc748d7b6c668ffd428c1f0726ff9a1fb5cc7b496098481778cbf41203a7eb3077a189ce7')
16 build() {
17   cd ${pkgname}-${pkgver}
19   export CXXFLAGS+=" -ffat-lto-objects"
20   ./configure --prefix=/usr
21   make
24 package() {
25   cd ${pkgname}-${pkgver}
27   install -d "${pkgdir}"/usr/bin
29   make DESTDIR="${pkgdir}" install
31   install -Dm 644 README "${pkgdir}"/usr/share/doc/scummvm-tools/README
32   install -Dm 644 convert_dxa.sh "${pkgdir}"/usr/share/doc/scummvm-tools/samples/convert_dxa.sh
34 #vim: sw=2 ts=2 et: