archrelease: copy trunk to community-any
[ArchLinux/community.git] / sdcv / trunk / PKGBUILD
blob0de716c76bab834a106167ab61a789da4573019d
1 # Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
3 pkgname=sdcv
4 pkgver=0.5.5
5 pkgrel=1
6 pkgdesc="StarDict Console Version"
7 arch=('x86_64')
8 url="https://dushistov.github.io/sdcv/"
9 license=('GPL')
10 depends=('glib2' 'readline' 'zlib')
11 makedepends=('cmake')
12 provides=('stardict')
13 changelog=$pkgname.changelog
14 source=($pkgname-$pkgver.tar.gz::https://github.com/Dushistov/$pkgname/archive/v$pkgver.tar.gz)
15 sha256sums=('4d2519e8f8479b9301dc91e9cda3e1eefef19970ece0e8c05f0c7b7ade5dc94b')
17 build() {
18   cd "${srcdir}"/$pkgname-$pkgver
20   install -d build
21   cd build
23   cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..
24   make
25   make lang
28 package() {
29   cd "${srcdir}"/$pkgname-$pkgver/build
31   make DESTDIR="${pkgdir}" install