archrelease: copy trunk to community-any
[ArchLinux/community.git] / sloccount / trunk / PKGBUILD
blob883ad3a51a4984393ed901aa16619b5668b491c0
1 # Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
2 # Contributor: Chris Brannon <cmbrannon79@gmail.com>
3 # Contributor: Allan McRae <allan@archlinux.org>
4 # Contributor: Christof Musik <christof@senfdax.de>
6 pkgname=sloccount
7 pkgver=2.26
8 pkgrel=10
9 pkgdesc='Tools for counting physical source lines of code'
10 url='https://www.dwheeler.com/sloccount/'
11 license=('GPL')
12 depends=('perl')
13 arch=('x86_64')
14 source=("https://www.dwheeler.com/$pkgname/$pkgname-$pkgver.tar.gz")
15 sha256sums=('fa7fa2bbf2f627dd2d0fdb958bd8ec4527231254c120a8b4322405d8a4e3d12b')
17 package() {
18   cd "$pkgname-$pkgver"
20   install -dm755 "$pkgdir/usr/bin"
21   make CC="gcc $CFLAGS $LDFLAGS $CPPFLAGS" PREFIX="$pkgdir/usr" install
22   mv "$pkgdir/usr/share/doc/sloccount-2.26-1" "$pkgdir/usr/share/doc/sloccount"
23   chmod 644 "$pkgdir/usr/share/doc/sloccount/"*
26 # vim: ts=2 sw=2 et: