archrelease: copy trunk to community-any
[ArchLinux/community.git] / snorenotify / repos / community-x86_64 / PKGBUILD
blob56a937abcf18313c44856cec6f195977bc7102ed
1 # Maintainer: Jiachen YANG <farseerfc@archinux.org>
2 # AUR Maintainer: Jaroslav Lichtblau <dragonlord@aur.archinux.org>
4 pkgname=snorenotify
5 pkgver=0.7.0
6 pkgrel=5
7 pkgdesc='Multi-platform Qt5 notification framework'
8 arch=('i686' 'x86_64')
9 url='https://github.com/Snorenotify/Snorenotify'
10 license=('LGPL3')
11 depends=('qt5-base' 'hicolor-icon-theme')
12 makedepends=('cmake' 'doxygen' 'extra-cmake-modules')
13 source=($pkgname-$pkgver.tar.gz::https://github.com/Snorenotify/Snorenotify/archive/v$pkgver.tar.gz)
14 sha256sums=('2e3f5fbb80ab993f6149136cd9a14c2de66f48cabce550dead167a9448f5bed9')
16 build() {
17   cd "${srcdir}"/$pkgname-$pkgver
19   cmake -DWITH_QT4=OFF -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib
20   make
23 package() {
24   cd "${srcdir}"/$pkgname-$pkgver
26   make DESTDIR="${pkgdir}" install