archrelease: copy trunk to community-any
[ArchLinux/community.git] / soapyairspy / trunk / PKGBUILD
blobd6979ac44a8e9461477d9fdc3cdbb5dd41f87366
1 # Maintainer: Filipe LaĆ­ns (FFY00) <lains@archlinux.org>
3 pkgname=soapyairspy
4 pkgver=0.2.0
5 _pkgname=SoapyAirspy
6 _gitver=soapy-airspy-$pkgver
7 pkgrel=1
8 pkgdesc='Soapy SDR plugin for the the Airspy'
9 arch=('x86_64')
10 url='https://github.com/pothosware/SoapyAirspy'
11 license=('GPL3')
12 depends=('soapysdr' 'airspy')
13 makedepends=('cmake')
14 source=("$pkgname-$pkgver.tar.gz::$url/archive/$_gitver.tar.gz")
15 sha512sums=('1ba873d093209e42883508dc30b7c605fe1f7bf0b5df613adb4941e976575f8f7f71fe99d57038ff51536c5a7a68a869412e47b4e3e112e633546778b5b0e8d4')
17 build() {
18   mkdir -p $_pkgname-$_gitver/build
19   cd $_pkgname-$_gitver/build
21   cmake .. \
22     -DCMAKE_INSTALL_PREFIX=/usr \
23     -DCMAKE_BUILD_TYPE=Release
25   make
28 package() {
29   cd $_pkgname-$_gitver/build
31   make DESTDIR="$pkgdir" install