1 # Maintainer: Frederik Schwan <freswa at archlinux dot org>
2 # Contributor: Ghost of Kendo <ghostofkendo at gmail dot com>
3 # Contributor: Thomas Dziedzic < gostrc at gmail >
4 # Contributor: Pierre Chapuis <catwell@archlinux.us>
5 # Contributor: Earnest <zibeon@gmail.com>
10 pkgdesc='Tool for the formal verification of distributed software systems'
12 url='https://spinroot.com/'
13 license=('custom:BSD3')
15 optdepends=('tcl: ispin graphical interface'
16 'swarm: improved performance on large verification problems'
17 'ispin: GUI for Spin')
18 source=("https://github.com/nimble-code/Spin/archive/version-${pkgver}.tar.gz")
19 b2sums=('a075043c55609de5860c3a428d356a9618a4062667e06d92797e1fb87cb4c805ac90ac580c7d9dfac1d5be1dda4c7f9c9f72927826b921c23710a858adb3eb4d')
22 cd Spin-version-${pkgver}/Src
27 # install binary and license file
28 cd Spin-version-${pkgver}/Src
29 install -Dm755 spin "${pkgdir}"/usr/bin/spin
30 install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.txt
32 # install manpage and docs
33 cd "${srcdir}"/Spin-version-${pkgver}
34 install -Dm644 -t "${pkgdir}"/usr/share/man/man1/ Man/spin.1
36 install -dm755 "${pkgdir}"/usr/share/doc/${pkgname}/examples
37 cp -a Examples/* "${pkgdir}"/usr/share/doc/${pkgname}/examples/