1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Sven Wick <sven.wick@gmx.de>
7 pkgdesc="A collection of tools making SSH more convenient"
9 url="https://github.com/vaporup/ssh-tools"
12 optdepends=('colordiff: colors for ssh-diff')
13 makedepends=('git' 'help2man')
14 _commit='fbf979f8a4f002a94ec2f487885aeebec49f80cb'
15 source=("$pkgname::git+$url.git#commit=$_commit")
21 git describe --tags | sed 's/^v//'
33 # dict with command:description pairings
35 pages["ssh-ping"]="check if host is reachable using ssh_config"
36 pages["ssh-version"]="shows version of the ssh server you are connecting to"
37 pages["ssh-diff"]="diff a file over ssh"
38 pages["ssh-facts"]="get some facts about the remote system"
39 pages["ssh-hostkeys"]="prints server host keys in several formats"
40 pages["ssh-keyinfo"]="prints keys in several formats"
41 pages["ssh-certinfo"]="shows validity and information of ssh certificates"
42 pages["ssh-force-password"]="enforces password authentication"
45 for page in "${!pages[@]}"; do
47 --name "${pages[${page}]}" \
48 --source "${pkgname^^}" \
50 --version-string "$pkgver" \
51 --output "man/${page}.1" \
60 install -vDm755 -t "$pkgdir/usr/bin" ssh-*
63 install -vDm644 -t "$pkgdir/usr/share/man/man1" man/*
66 install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md