archrelease: copy trunk to community-any
[ArchLinux/community.git] / stellarsolver / trunk / PKGBUILD
blob6e02a738a3ce9e4b324f7b02164149746e655916
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=stellarsolver
4 pkgver=2.4
5 pkgrel=3
6 pkgdesc='The cross platform Sextractor and Astrometry.net-Based internal astrometric solver'
7 arch=(x86_64)
8 url='https://github.com/rlancaste/stellarsolver'
9 license=(GPL3)
10 depends=(qt5-base gsl wcslib hicolor-icon-theme)
11 makedepends=(cmake)
12 source=(https://github.com/rlancaste/stellarsolver/archive/$pkgver/$pkgname-$pkgver.tar.gz)
13 sha256sums=('e9cf7e73edb96a959f75dbbba16bd5e270f6e95c0d5c3dfa8727dfaf77d0617f')
15 build() {
16   cmake -B build -S $pkgname-$pkgver \
17     -DCMAKE_INSTALL_PREFIX=/usr \
18     -DBUILD_TESTER=ON
19   cmake --build build
22 package() {
23   DESTDIR="$pkgdir" cmake --install build