archrelease: copy trunk to community-any
[ArchLinux/community.git] / stumpwm-contrib / trunk / PKGBUILD
blobf8d3d81d793b2a13f3d3e7aad513cee7c67a924f
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
3 pkgname=stumpwm-contrib
4 pkgver=r515.g4613a95
5 pkgrel=2
6 pkgdesc='Collection of StumpWM modules'
7 arch=('any')
8 url='https://github.com/stumpwm/stumpwm-contrib'
9 license=('GPL2')
10 depends=('stumpwm')
11 makedepends=('git')
12 optdepends=(
13   'xorg-xprop: for stumpish, the StumpWM Interactive Shell'
14   'rlwrap: command completion and history in stumpish'
15   'alsa-utils: manipulate the volume using amixer'
16   'mpd: display information about mpd'
17   'surfraw: surf the internet'
18   'pass: pass integration'
19   'pinentry: gnupg agent integration'
21 _commit='4613a956add7a17986a3b26c341229466cd13f1d'
22 source=("$pkgname::git+$url#commit=$_commit")
23 b2sums=('SKIP')
25 pkgver() {
26   cd "$pkgname"
28   printf 'r%s.g%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
31 package() {
32   cd "$pkgname"
34   install -vd "$pkgdir/usr/share/stumpwm/contrib"
36   # skip useless directories/files
37   find . \
38     -maxdepth 1 \
39     -mindepth 1 \
40     -type d \
41     -not -path './docs' \
42     -not -path './.git' \
43     -exec cp -ra {} "$pkgdir/usr/share/stumpwm/contrib" \;
45   # documentation
46   install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" README.org