archrelease: copy trunk to community-any
[ArchLinux/community.git] / subtitleeditor / repos / community-x86_64 / PKGBUILD
blob9fa3787d5a1981ffdf0cf26f1a25f24704636847
1 # Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
3 pkgname=subtitleeditor
4 pkgver=0.54.0
5 pkgrel=5
6 pkgdesc="A GTK+3 tool to edit subtitles for GNU/Linux/*BSD"
7 arch=('x86_64')
8 url="https://kitone.github.io/subtitleeditor/"
9 license=('GPL3')
10 depends=('desktop-file-utils' 'enchant' 'gst-plugins-base' 'gstreamermm' 'gst-libav'
11          'gtkmm3' 'hicolor-icon-theme' 'libsigc++' 'libxml++2.6' 'xdg-utils')
12 makedepends=('intltool')
13 changelog=$pkgname.changelog
14 source=(https://github.com/kitone/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz)
15 sha256sums=('aa9c539f3a0984deef257339e2b9f5c8728b8245113695cf6d42459f011aa2ab')
18 prepare() {
19   cd "${srcdir}"/$pkgname-$pkgver
20 # enchant-2 naming change
21   sed -i 's/enchant >=/enchant-2 >=/' configure
24 build() {
25   cd "${srcdir}"/$pkgname-$pkgver
27   ./configure --prefix=/usr
28   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
29   make
32 package () {
33   cd "${srcdir}"/$pkgname-$pkgver
35   make DESTDIR="${pkgdir}" install