archrelease: copy trunk to community-any
[ArchLinux/community.git] / synapse / trunk / PKGBUILD
blob11655bb1aa9385a1f260d962163a071841e59d78
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Alessio Sergi <asergi at archlinux dot us>
4 pkgname=synapse
5 pkgver=0.2.99.4
6 pkgrel=2
7 pkgdesc="A semantic file launcher"
8 arch=('x86_64')
9 url="https://launchpad.net/synapse-project"
10 license=('GPL3')
11 depends=('libkeybinder3' 'hicolor-icon-theme' 'json-glib' 'libgee' 'libnotify' \
12          'zeitgeist' 'rest' 'xdg-utils')
13 makedepends=('intltool' 'vala')
14 optdepends=('bc: calculator plugin'
15             'devhelp: documentation plugin'
16             'gnome-dictionary: dictionary plugin'
17             'openssh: ssh plugin'
18             'pastebinit: pastebin plugin'
19             'rhythmbox: rhythmbox plugin'
20             'xnoise: xnoise plugin')
21 source=("https://launchpad.net/$pkgname-project/0.3/$pkgver/+download/$pkgname-$pkgver.tar.xz")
22 sha512sums=('d9668fb9dd18d97da89bf5f0a9864f843c629f91751b326b4e97de74c6db64a59dbcd221f1b6ed0fc199a683ed511d86f280756fe4c21195d6169d2977315325')
24 build() {
25   cd "$srcdir/$pkgname-$pkgver"
27   ./configure --prefix=/usr
28   make
31 package() {
32   cd "$srcdir/$pkgname-$pkgver"
34   make DESTDIR="$pkgdir/" install
37 # vim:set ts=2 sw=2 et: