archrelease: copy trunk to community-any
[ArchLinux/community.git] / system-tools-backends / trunk / PKGBUILD
blob5ceada464e61453ea94c14d4fb95c95b49753c36
1 # Maintainer : Martin Wimpress <code@flexion.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Hugo Doria <hugo@archlinux.org>
5 pkgname=system-tools-backends
6 pkgver=2.10.2
7 pkgrel=5
8 pkgdesc='Backends for Gnome/MATE System Tools.'
9 arch=('x86_64')
10 url='http://system-tools-backends.freedesktop.org/'
11 license=('GPL')
12 depends=('dbus-glib' 'perl' 'perl-net-dbus' 'polkit')
13 makedepends=('intltool' 'perl-xml-parser')
14 source=("https://download.gnome.org/sources/${pkgname}/2.10/${pkgname}-${pkgver}.tar.bz2")
15 sha256sums=('1dbe5177df46a9c7250735e05e77129fe7ec04840771accfa87690111ca2c670')
17 build() {
18     cd "${pkgname}-${pkgver}"
19     ./configure \
20         --prefix=/usr \
21         --with-dbus-sys=/etc/dbus-1/system.d \
22         --localstatedir=/var \
23         --mandir=/usr/share \
24         --sbindir=/usr/bin \
25         --disable-static
26     make
29 package() {
30     cd "${pkgname}-${pkgver}"
31     make DESTDIR="${pkgdir}" install
32     #clean up man
33     rm -rf "${pkgdir}/usr/share/system-tools-backends-2.0/modules/share/"