archrelease: copy trunk to community-any
[ArchLinux/community.git] / systemd-ui / trunk / PKGBUILD
blob8afac9d36a682afc4662c00cffb16a7ce6096808
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: Jameson Pugh <imntreal@gmail.com>
4 pkgname=systemd-ui
5 pkgver=3
6 pkgrel=5
7 pkgdesc="Graphical front-end for systemd"
8 arch=('x86_64')
9 url="https://www.freedesktop.org/wiki/Software/systemd"
10 license=('GPL')
11 depends=('gtk3' 'libgee' 'libnotify')
12 makedepends=('vala' 'docbook-xsl' 'libxslt')
13 source=(https://www.freedesktop.org/software/systemd/$pkgname-$pkgver.tar.xz
14         systemadm.appdata.xml)
15 sha256sums=('455e65000abf39bbccd937786b5f0d7c76ea631b6f28d7142f007fa141338dad'
16             '2d335848d3810e34baa1efada6bb48c459c75e7007db3c7065a9e0d7325adefb')
18 build() {
19   cd $pkgname-$pkgver
20   ./configure --prefix=/usr
21   make
24 package() {
25   cd $pkgname-$pkgver
26   make DESTDIR="$pkgdir" install
27   install -Dm644 ../systemadm.appdata.xml "$pkgdir/usr/share/metainfo/systemadm.appdata.xml"