archrelease: copy trunk to community-any
[ArchLinux/community.git] / systemtap / trunk / PKGBUILD
blob127276f94f9ddbdaf621c7faf24827829539b396
1 # Maintainer : Christian Rebischke <Chris.Rebischke@archlinux.org>
2 # Contributor:dront78 <dront78@gmail.com>
3 pkgname=systemtap
4 pkgver=3.2
5 pkgrel=1
6 pkgdesc="provides infrastructure to simplify the gathering of information about the running system."
7 url="http://sourceware.org/systemtap/"
8 arch=('x86_64')
9 license=('GPL')
10 depends=('elfutils' 'nss' 'python2')
11 makedepends=('python2-setuptools' 'xmlto')
12 optdepends=('sqlite3: for storing results in a database')
13 source=("${pkgname}-${pkgver}.tar.gz::https://sourceware.org/systemtap/ftp/releases/${pkgname}-${pkgver}.tar.gz"
14         "${pkgname}-${pkgver}.tar.gz.asc::https://sourceware.org/systemtap/ftp/releases/${pkgname}-${pkgver}.tar.gz.asc"
15         'access_process_vm_h.patch')
16 sha512sums=('6036ed1b5189fd3fcfdeeaa526a3539ac632d0b687a063b5e3424e8f613bfc2c8d079742b0262b547128e97e30e4beb61898b23761657aee519e61346ac92e94'
17             'SKIP'
18             'f33d81d2e4d0892cb248e89eb11b76d390f78ef7e50dca8d15e0a868c1a42fb0fc40ea69d6d967ebd65dd7d7a910bf8b2faf31378dc744ef1e13aeb423a2572b')
19 install='systemtap.install'
20 validpgpkeys=('5D38116FA4D3A7CC77E378D37E83610126DCC2E8')
22 prepare() {
23   cd "${pkgname}-${pkgver}"
24   patch -Np1 -i "${srcdir}/access_process_vm_h.patch"
26 build() {
27   cd "${pkgname}-${pkgver}"
28   ./configure \
29     --prefix=/usr \
30     --sysconfdir=/etc \
31     --libexecdir=/usr/lib/"${pkgname}" \
32     --libdir=/usr/lib/"${pkgname}" \
33     --mandir=/usr/share/man/ \
34     --localstatedir=/var \
35     --enable-pie \
36     --disable-docs \
37     --enable-htmldocs
38   make
41 package() {
42   cd "${srcdir}/${pkgname}-${pkgver}"
43   make DESTDIR="${pkgdir}" install
44   rmdir "${pkgdir}/var/run/stap-server/"
45   rmdir "${pkgdir}/var/run/"