archrelease: copy trunk to community-any
[ArchLinux/community.git] / tap-plugins / trunk / PKGBUILD
blob611387671985541c3fa670ea6edebe37696a124b
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: speps <speps at aur dot archlinux dot org>
3 # Contributor: Ng Oon-Ee <ngoonee.talk@gmail.com>
5 pkgname=tap-plugins
6 pkgver=1.0.1
7 pkgrel=2
8 pkgdesc="Tom's LADSPA Plugins"
9 arch=(x86_64)
10 url="http://tap-plugins.sourceforge.net/"
11 license=(GPL2)
12 groups=(
13   ladspa-plugins
14   pro-audio
16 depends=(glibc)
17 makedepends=(ladspa)
18 source=(https://github.com/tomszilagyi/$pkgname/archive/v$pkgver/$pkgname-v$pkgver.tar.gz)
19 sha512sums=('25f72bba83a5a40d480bc9d4659b64096102281d02e43ad93d5064b0ef7972184db40162d1ef78fd783f431740a4c4d5e03160cdd5f43da3bc1570ff462c863a')
20 b2sums=('2b8ac9a26197f5c980512d33daf4c604d7bb3046fb40e3826d559d4420921a0e124a5577d53d0896bc92111f69765f714d5f55a9da60546e2e6f29e5c851b2a5')
22 prepare() {
23   # correct install path and add external LDFLAGS to achieve full RELRO
24   sed -e 's|/usr/local/|$(DESTDIR)/usr/|; s/LDFLAGS = /LDFLAGS += /g' -i $pkgname-$pkgver/Makefile
27 build() {
28   make -C $pkgname-$pkgver
31 package() {
32   make DESTDIR="$pkgdir/" install -C $pkgname-$pkgver
33   install -vDm 644 $pkgname-$pkgver/{CREDITS,README} -t "$pkgdir/usr/share/doc/$pkgname/"