archrelease: copy trunk to community-any
[ArchLinux/community.git] / thrift / trunk / PKGBUILD
blobfbfba28890b8384d89c9945ceabc627963a46c79
1 # Maintainer: Anatol Pomozov
2 # Contributor: Byron Clark <byron@theclarkfamily.name>
4 # This package contains only thrift compiler and C/C++ libraries
5 # for all the language binding one should use corresponding language-specific package manager:
6 # CPAN for perl, gem for ruby, pip for python etc... Or better to create arch packages that install
7 # the binding from the language specific managers python2-thrift, perl-thrift, ruby-thrift, ...
9 pkgname=thrift
10 pkgver=0.18.1
11 pkgrel=1
12 pkgdesc='Scalable cross-language services framework for IPC/RPC'
13 arch=(x86_64)
14 url='https://thrift.apache.org'
15 license=(APACHE)
16 depends=(gcc-libs openssl)
17 makedepends=(qt5-base boost libevent emacs-nox)
18 optdepends=(
19   'qt5-base: TQTcpServer (Qt5) support'
21 options=(!lto) # https://issues.apache.org/jira/browse/THRIFT-5498
22 source=(thrift-$pkgver.zip::https://github.com/apache/thrift/archive/v$pkgver.zip)
23 sha256sums=('5f803ff19acd6dc0e3857bbe46e1b01ba18526ea41342a36ab17ef18ede92017')
25 build() {
26   cd thrift-$pkgver
28   ./bootstrap.sh
29   ./configure --prefix=/usr \
30               --enable-plugin \
31               --with-cpp \
32               --with-c_glib \
33               --with-qt5 \
34               --with-libevent \
35               --with-csharp \
36               --without-haskell \
37               --without-php \
38               --without-ruby \
39               --without-python \
40               --without-erlang \
41               --without-perl \
42               --without-java \
43               --without-c_sharp \
44               --without-d \
45               --without-php \
46               --without-go \
47               --without-lua \
48               --without-nodejs
49               
50   make
52   emacs -Q --batch -f batch-byte-compile contrib/thrift.el
55 check() {
56   cd thrift-$pkgver
57 #  make check
60 package() {
61   cd thrift-$pkgver
62   make DESTDIR="$pkgdir" install
64   install -m0644 -D contrib/thrift.vim "$pkgdir"/usr/share/vim/vimfiles/syntax/thrift.vim
65   install -m0644 -D contrib/thrift.el "$pkgdir"/usr/share/emacs/site-lisp/thrift.el
66   install -m0644 -D contrib/thrift.elc "$pkgdir"/usr/share/emacs/site-lisp/thrift.elc