archrelease: copy trunk to community-any
[ArchLinux/community.git] / tinyemu / trunk / PKGBUILD
bloba5c29d751d1037db116889c98bd876fd252ea50d
1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
3 pkgname=tinyemu
4 pkgver=2019_12_21
5 pkgrel=3
6 pkgdesc='RISC-V system emulator'
7 arch=(x86_64)
8 groups=(risc-v)
9 url='https://bellard.org/tinyemu/'
10 license=(MIT)
11 depends=(curl sdl)
12 makedepends=(setconf)
13 source=("$url$pkgname-${pkgver//_/-}.tar.gz")
14 sha256sums=('be8351f2121819b3172fcedce5cb1826fa12c87da1b7ed98f269d3e802a05555')
16 prepare() {
17   local m="$pkgname-${pkgver//_/-}/Makefile"
18   setconf "$m" bindir="/usr/bin"
19   setconf "$m" CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -MMD $CFLAGS -w"
20   setconf "$m" LDFLAGS="$LDFLAGS"
23 build() {
24   make -C "$pkgname-${pkgver//_/-}"
27 package() {
28   cd "$pkgname-${pkgver//_/-}"
29   install -d "$pkgdir/usr/bin"
30   make DESTDIR="$pkgdir" install
31   install -Dm644 readme.txt \
32     "$pkgdir/usr/share/doc/$pkgname/readme.txt"
33   install -Dm644 MIT-LICENSE.txt \
34     "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
37 # vim: ts=2 sw=2 et: