archrelease: copy trunk to community-any
[ArchLinux/community.git] / tomlplusplus / trunk / PKGBUILD
blob1f32cba2d30bf251612c56d00c1fbd543fa695b8
1 # Maintainer: David Runge <dvzrv@archlinux.org>
3 pkgname=tomlplusplus
4 pkgver=3.3.0
5 pkgrel=1
6 pkgdesc="Header-only TOML config file parser and serializer for C++17"
7 arch=(x86_64)
8 url="https://marzer.github.io/tomlplusplus/"
9 license=(MIT)
10 depends=(gcc-libs glibc)
11 makedepends=(cmake meson)
12 provides=(libtomlplusplus.so)
13 source=($pkgname-$pkgver.tar.gz::https://github.com/marzer/$pkgname/archive/refs/tags/v$pkgver.tar.gz)
14 sha512sums=('b3e9933719bdddca9c38ed269f90bccac59407c87f58a885e0ed818aee147758a7279c8c1406516ee95df92a2bde9dd3d6551faf2c84e537315871a9f1a1ff95')
15 b2sums=('26031acaa2a26006fdc8888764c3448d360df2251503d4fb044f8904277a6807fe8606bacff78689e0ba891d50e756ebb84fa5c086bf41c1723be64aa3459500')
17 build() {
18   arch-meson $pkgname-$pkgver build
19   ninja -C build
22 package() {
23   meson install -C build --destdir "$pkgdir"
24   install -vDm 644 $pkgname-$pkgver/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"