1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
6 pkgdesc='HTTP Framework for REST Applications in C'
8 url=https://github.com/babelouest/ulfius
27 provides=(libulfius.so)
28 _tag=3d40004de21c5d379568ef943a23b030a3f03922
29 source=(git+https://github.com/babelouest/ulfius.git#tag=${_tag})
30 validpgpkeys=(8405B02FCC28EF9744C8F253FE82139440BD22B9) # Nicolas Mora <nicolas@babelouest.org>
35 git describe --tags | sed 's/^v//'
39 cmake -S ulfius -B build -G Ninja \
40 -DCMAKE_BUILD_TYPE=None \
41 -DCMAKE_INSTALL_PREFIX=/usr \
42 -DBUILD_ULFIUS_DOCUMENTATION=ON
47 DESTDIR="${pkgdir}" ninja -C build install
48 cp -dr --no-preserve=ownership ulfius/doc/html "${pkgdir}"/usr/share/doc/ulfius/