archrelease: copy trunk to community-any
[ArchLinux/community.git] / unrealircd / repos / community-x86_64 / PKGBUILD
blob3e6af3086ed6d343e34c4310d498e8ceff13ba42
1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
2 # Contributor: Zerial <fernando@zerial.org>
4 pkgname=unrealircd
5 pkgver=6.1.0
6 pkgrel=1
7 pkgdesc="Open Source IRC Server"
8 arch=('x86_64')
9 url="https://www.unrealircd.org"
10 license=('GPL2')
11 depends=('openssl' 'curl' 'c-ares' 'tre' 'pcre2' 'libnsl' 'argon2')
12 conflicts=('ircd')
13 provides=('ircd')
14 backup=('etc/unrealircd/unrealircd.conf')
15 install=unrealircd.install
16 validpgpkeys=('1D2D2B03A0B68ED11D68A24BA7A21B0A108FF4A9')
17 source=(https://www.unrealircd.org/unrealircd4/unrealircd-$pkgver.tar.gz{,.asc}
18         unrealircd.service
19         unrealircd.tmpfiles.d
20         unrealircd.sysusers.d
21         install.pl
22         source-date-epoch.patch)
23 sha256sums=('b09c09f9b47b02e56f8da1745b8f00c70f1e0f53faa931700eaf74d7a9df6591'
24             'SKIP'
25             '5bb6016c379e6f040d8c625e3339c096ff66c4450aa024ca5b13ad3dec47c38e'
26             '91b5e1d623b51ffd4734d73e35cead09be596460c41b9440406f92c9e2b4b9b1'
27             '9e595176e63b301476982b1456d6ed065c479ff913b6743417ab8a9efdda0e3a'
28             '43f07093ada8eb5c954f9e2e189610575906c690c0953fec041d4f2d31210d85'
29             '1b9b3d5560f6633d4f31a521bc0ae17094d3afa28e703b4790eaefedcc9a92a8')
31 prepare() {
32   cd unrealircd-$pkgver
33   sed -i \
34     -e 's|$(INSTALL) -m 0700|$(INSTALL) -m 0755|g' \
35     -e 's|$(INSTALL) -m 0600|$(INSTALL) -m 0644|g' \
36     Makefile.in
37 #  patch -p1 < ../source-date-epoch.patch
40 build() {
41   cd unrealircd-$pkgver
42   ./configure \
43     --with-pidfile=/run/unrealircd/ircd.pid \
44     --with-showlistmodes \
45     --enable-ssl=/usr \
46     --with-bindir=/usr/bin \
47     --with-datadir=/var/lib/unrealircd \
48     --with-controlfile=/run/unrealircd/unrealircd.ctl \
49     --with-confdir=/etc/unrealircd \
50     --with-modulesdir=/usr/lib/unrealircd \
51     --with-logdir=/var/log/unrealircd \
52     --with-cachedir=/var/cache/unrealircd \
53     --with-docdir=/usr/share/doc/unrealircd \
54     --with-tmpdir=/tmp \
55     --with-scriptdir=/usr \
56     --with-nick-history=2000 \
57     --with-sendq=3000000 \
58     --with-permissions=0644 \
59     --with-fd-setsize=1024 \
60     --enable-dynamic-linking
61   make
64 package() {
65   cd unrealircd-$pkgver
67   export pkgdir
68 #  make INSTALL="$srcdir"/install.pl install DESTDIR="$pkgdir"
69   make install DESTDIR="$pkgdir"
70   mv "$pkgdir"/usr/unrealircd "$pkgdir"/etc/unrealircd/unrealircd
71   cp "$pkgdir"/etc/unrealircd/examples/example.conf "$pkgdir"/etc/unrealircd/unrealircd.conf
72   rm -rf "$pkgdir"/tmp
74   install -Dm0644 "$srcdir"/unrealircd.service "$pkgdir"/usr/lib/systemd/system/unrealircd.service
75   install -Dm0644 "$srcdir"/unrealircd.tmpfiles.d "$pkgdir"/usr/lib/tmpfiles.d/unrealircd.conf
76   install -Dm0644 "$srcdir"/unrealircd.sysusers.d "$pkgdir"/usr/lib/sysusers.d/unrealircd.conf