archrelease: copy trunk to community-any
[ArchLinux/community.git] / volatility3 / repos / community-any / PKGBUILD
bloba94021a68dc93da791d302030bcd8fb524f270e3
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Limao Luo <luolimao+AUR@gmail.com>
3 # Contributor: Wes Brown <wesbrown18@gmail.com>
5 pkgname=volatility3
6 pkgver=2.4.1
7 pkgrel=2
8 pkgdesc='Advanced memory forensics framework'
9 url='https://github.com/volatilityfoundation/volatility3/wiki'
10 arch=('any')
11 license=('custom')
12 depends=(
13   'python' 'python-yara' 'python-capstone' 'python-jsonschema'
14   'python-pycryptodome' 'python-pefile' 'python-snappy')
15 makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
16 provides=('volatility')
17 replaces=('volatility')
18 source=(https://github.com/volatilityfoundation/volatility3/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
19 sha512sums=('5f785a778654b76fc85b7b82b2e9ba9e6315a99169d4d956a9af84ae91086e7a38cac343b7df0f00d6830361c77d377408bf8eab3679c161c8a02212c696389c')
20 b2sums=('7f00ec6b57eb9ef6420f4c1aa735203fbd51fca39aa13200eb821d13842f879c8743f63da7c5bbcf7d84a2850709a15c0aadc2b0311edbdf34dfa026f2a3dcd6')
22 build() {
23   cd ${pkgname}-${pkgver}
24   python -m build --wheel --no-isolation
27 package() {
28   cd ${pkgname}-${pkgver}
29   python -m installer --destdir="${pkgdir}" dist/*.whl
30   install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
31   install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
34 # vim: ts=2 sw=2 et: