archrelease: copy trunk to community-any
[ArchLinux/community.git] / wishbone-utils / trunk / PKGBUILD
blob7393bcbe3b40f7bc5f8f2606bc43f75e5e46f5f5
1 # Maintainer: Jelle van der Waa <jelle@archlinux.org>
2 # Maintainer: Daurnimator<daurnimator@archlinux.org>
4 pkgname=wishbone-utils
5 pkgver=0.7.8
6 pkgrel=1
7 pkgdesc='Utilities for working with a Wishbone bridge'
8 arch=(x86_64)
9 url="https://github.com/litex-hub/wishbone-utils"
10 license=(BSD)
11 depends=(glibc gcc-libs)
12 makedepends=(rust)
13 source=($pkgname-$pkgver.tar.gz::https://github.com/litex-hub/wishbone-utils/archive/v$pkgver.tar.gz)
14 sha512sums=('ca61e335f97c3e5ed0b02d71601c4d2102c87ea40051f7345514c1624c06bdaa47bb6acca66c0709968c9e39faf570f49e5ec81cb444909029498043240e506d')
16 build() {
17   cd $pkgname-$pkgver/wishbone-tool
18   cargo build --release --locked
21 check() {
22   cd $pkgname-$pkgver/wishbone-tool
23   cargo test --release --locked
26 package() {
27   cd $pkgname-$pkgver
28   install -Dm 755 wishbone-tool/target/release/wishbone-tool -t "${pkgdir}/usr/bin/"
29   install -D -m644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"