archrelease: copy trunk to community-any
[ArchLinux/community.git] / xcur2png / repos / community-x86_64 / PKGBUILD
blobf682f9e4f84e486bcddfac579fbefd203430f9a5
1 # Maintainer: Christian Hesse <mail@eworm.de>
2 # Contributor: Jarred Leonardo <jarredleonardo at googlemail dot com>
4 pkgname=xcur2png
5 pkgver=0.7.1
6 pkgrel=7
7 pkgdesc='Convert X cursors to PNG images'
8 arch=('x86_64')
9 url='https://github.com/eworm-de/xcur2png'
10 license=('GPL')
11 depends=('libpng' 'libxcursor')
12 source=("https://github.com/eworm-de/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"
13         '0001-fix-wrong-math.patch')
14 sha256sums=('bc6a062fdb48615a7159ed56ef3d2011168cd8a9decaf1d8a4e316d3064132c9'
15             '224cf894c53eeb647a696ff311054cecf1a3dfeb10f49d96293c8bfeba4b88e9')
17 prepare() {
18   cd "${srcdir}/${pkgname}-${pkgver}"
20   patch -Np1 < ../0001-fix-wrong-math.patch
23 build() {
24   cd "${srcdir}/${pkgname}-${pkgver}"
26   ./configure \
27     --prefix=/usr
28   make
31 package() {
32   cd "${srcdir}/${pkgname}-${pkgver}"
34   make DESTDIR="${pkgdir}" install