1 # Maintainer: T.J. Townsend <blakkheim@archlinux.org>
2 # Maintainer: Caleb Maclennan <caleb@alerque.com>
3 # Contributor: Christopher Bayliss <christopher.j.bayliss@gmail.com>
4 # Contributor: Albert De La Fuente Vigliotti
5 # Contributor: Stefan Husmann <stefan-husmann@t-online.de>
11 pkgdesc='A Bible study tool for GTK3'
13 url='https://xiphos.org'
15 depends=('biblesync' 'dbus-glib' 'icu' 'libbiblesync.so' 'libicui18n.so'
16 'minizip' 'sword>=1.9.0' 'webkit2gtk')
17 makedepends=('appstream-glib' 'cmake' 'docbook-utils' 'gnome-common' 'gtkmm'
18 'intltool' 'libffi' 'libxml2' 'python' 'zlib' 'zip')
19 source=("https://github.com/crosswire/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
20 "https-by-default.patch"
22 "disable-webkit-editor.patch")
23 sha256sums=('d34353f62224302c924757fca55ff0fc19f96815f20b893279ceef3d7d054128'
24 '3630dee5f9f05600e1a726b91a89e2eb17615a73d30548de303e7b29ec2286d2'
25 'd1669dced24a5d6d9a76ab033fc89201855285b76a1e80ef3fe695242d1c401d'
26 'b8e7e8da6eaa246f7f6ff952bf4b5bc87a7274a6e71ae311fad55da2c43aa5af')
30 # https://github.com/crosswire/xiphos/issues/1083
31 patch -Np0 -i ../xiphos-glibc.patch
32 # disable study pad as it requires a very old webkitgtk
33 # https://github.com/crosswire/xiphos/issues/794
34 patch -Np1 -i ../disable-webkit-editor.patch
35 # avoid fetching modules over plaintext ftp
36 patch -Np1 -i ../https-by-default.patch
40 cmake -B build -S "$pkgname-$pkgver" \
41 -DCMAKE_BUILD_TYPE=None \
42 -DCMAKE_INSTALL_PREFIX=/usr \
48 DESTDIR="$pkgdir" cmake --install build