archrelease: copy trunk to community-any
[ArchLinux/community.git] / xmake / trunk / PKGBUILD
blob122bae30b4762ac8adca9f9b3fd7e755a47fdbcc
1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
2 # Contributor: <waruqi@gmail.com>
3 # Contributor: lumpyzhu <lumpy.zhu@gmail.com>
5 pkgname=xmake
6 pkgver=2.7.9
7 pkgrel=1
8 pkgdesc='A cross-platform build utility based on Lua'
9 arch=(x86_64 i686 aarch64)
10 url="https://github.com/xmake-io/$pkgname"
11 license=(Apache)
12 makedepends=(ncurses
13              readline)
14 _archive="$pkgname-$pkgver"
15 source=("$url/releases/download/v$pkgver/${_archive/-/-v}.tar.gz")
16 sha256sums=('9b42d8634833f4885b05b89429dd60044dca99232f6096320b8d857fb33d2aef')
18 build() {
19         cd "$_archive"
20         ./configure
21         make
24 package() {
25         cd "$_archive"
26         make install DESTDIR="$pkgdir" PREFIX="/usr"