1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Yiyao Yu <yuydevel at protonmail dot com>
3 # Contributor: Moritz Lipp <mlq@pwmt.org>
8 pkgdesc='A tool to generate compilation database for clang tooling'
10 url='https://github.com/rizsotto/Bear'
33 _commit='0c48ae75892c8ace741a87209e7293c50687c9f0'
34 source=("$pkgname::git+$url.git#commit=$_commit")
43 # XXX if this is moved to build, tests fail.
44 # there must be some environment variables that
45 # are discarded inbetween functions.
50 -DCMAKE_INSTALL_PREFIX=/usr \
51 -DCMAKE_INSTALL_SYSCONFDIR=/etc \
52 -DCMAKE_INSTALL_LIBEXECDIR="lib/$pkgname"
60 DESTDIR="$pkgdir" cmake --install build