archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / bully / trunk / PKGBUILD
blobfa10b00ab90a598419c7a2f91fd910bcf8a494a2
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Ľubomír 'The_K' Kučera <lubomir-dot-kucera-dot-jr-at-gmail-dot-com>
4 pkgname=bully
5 pkgver=1.1.12.g04185d7
6 pkgrel=2
7 _gitcommit=04185d7b1d1a7909f47f23fbd85691401c7fabd7
8 pkgdesc='Retrieve WPA/WPA2 passphrase from a WPS enabled access point'
9 url='https://github.com/aanarchyy/bully'
10 arch=('x86_64')
11 license=('GPL3')
12 depends=('glibc' 'libpcap' 'aircrack-ng')
13 optdepends=('pixiewps: pixiewps support')
14 makedepends=('git')
15 source=(${pkgname}::"git+https://github.com/aanarchyy/bully#commit=${_gitcommit}")
16 sha512sums=('SKIP')
18 pkgver() {
19   cd ${pkgname}
20   git describe --tags --always|sed 's/^v//;s/-/./g'
23 build() {
24   cd ${pkgname}
25   make -C src
28 package() {
29   cd ${pkgname}
30   make -C src install DESTDIR="${pkgdir}" prefix=/usr
33 # vim: ts=2 sw=2 et: