archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / cgrep / trunk / PKGBUILD
blobbb26f39254463e73d748f4fdc2c8073dc0cbcdb2
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 pkgname=cgrep
5 pkgver=6.6.32
6 pkgrel=373
7 pkgdesc="A context-aware grep for source codes"
8 url="https://awgn.github.io/cgrep/"
9 license=("GPL2")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-aeson' 'haskell-ansi-terminal' 'haskell-async' 'haskell-cmdargs'
12          'haskell-dlist' 'haskell-either' 'haskell-extra' 'haskell-regex-base'
13          'haskell-regex-pcre' 'haskell-regex-posix' 'haskell-safe' 'haskell-split'
14          'haskell-stringsearch' 'haskell-unix-compat' 'haskell-unicode-show'
15          'haskell-unordered-containers' 'haskell-utf8-string' 'haskell-yaml')
16 makedepends=('ghc')
17 source=("https://hackage.haskell.org/packages/archive/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
18 sha512sums=('401ca49fbd2903b810c1873a3c52c3863a42b431d1a905a781636386c3ac0aac4e2ed9934fb24f1e9996629a2b578483a7c3a7a8a4d61ecb7ac7cfc9152f43ba')
20 build() {
21     cd $pkgname-$pkgver
23     runhaskell Setup configure -O --prefix=/usr --ghc-option='-pie' \
24                                --enable-executable-dynamic --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname
25     runhaskell Setup build $MAKEFLAGS
28 package() {
29     cd $pkgname-$pkgver
30     runhaskell Setup copy --destdir="$pkgdir"