1 # Maintainer: Filipe LaĆns (FFY00) <lains@archlinux.org>
2 # Maintainer: Daniel Bermond <dbermond@archlinux.org>
8 pkgdesc='Open source speech codec designed for communications quality speech between 450 and 3200 bit/s'
11 url='https://github.com/drowe67/codec2'
15 source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
16 sha512sums=('692feea8ff99430a7ed8efa5bf48a633dc9689b1f39009cf1f907315e600da26ea3787a994b51d7ca9d4cbc8b8c9b26f89031af899f114fa130f0703266a6b17')
19 cmake -B build -S $pkgname-$pkgver \
20 -DCMAKE_BUILD_TYPE=Release \
21 -DCMAKE_INSTALL_PREFIX=/usr \
22 -DCMAKE_SKIP_RPATH=YES \
29 make -C build DESTDIR="$pkgdir" install
32 while read -r -d '' _bin
34 install -D -m755 "$_bin" -t "$pkgdir/usr/bin"
35 done < <(find build -type f -regextype posix-extended \
36 -regex '.*/(c2(demo|dec|enc|sim)|ch|freedv_(t|r)x|(cohpsk|fdmdv|fsk|ldpc|ofdm)_.*)' \
38 mv "$pkgdir/usr/bin"/{ch,c2ch}