1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Maintainer: Baptiste Jonglez <archlinux at bitsofnetworks dot org>
3 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
4 # Contributor: ViNS <gladiator@fastwebnet.it>
9 pkgdesc='Collection of tools for network auditing and penetration testing'
10 url='https://www.monkey.org/~dugsong/dsniff/'
13 depends=('glibc' 'libpcap' 'openssl' 'libxmu' 'glib2' 'libnet' 'libnids' 'libtirpc')
14 makedepends=('rpcsvc-proto')
15 options=('!makeflags')
16 source=(https://www.monkey.org/~dugsong/${pkgname}/beta/${pkgname}-${pkgver}.tar.gz
17 https://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_2.4b1+debian-30.debian.tar.xz
18 dsniff-macof-size-calculation.patch
19 dsniff-httppostfix.patch)
20 sha256sums=('a9803a7a02ddfe5fb9704ce86f0ffc48453c321e88db85810db411ba0841152a'
21 '5fcdcc4525e1b4c2aa0208a8543024735bc07096ff1ee6f895eee4e2cf453144'
22 'd8f5cc5d14a614410a84a8eaba5a4212ee03466c4fe2fd4a634f5d7c3f688ec7'
23 '3efd6ca2267540016e843af3e8d7720d888fd17a73cba410e2c68022fd3a7baf')
28 # apply bundled patches via series
29 while IFS='' read -r patch || [[ -n "${patch}" ]]; do
30 echo "** Applying patch ${patch}"
31 patch -Np1 < "../debian/patches/${patch}"
32 done < ../debian/patches/series
35 for _patch in "${source[@]}"; do
37 if [[ "${_patch}" =~ \.patch$ ]]; then
38 echo "** Applying patch ${_patch}"
39 patch -Np1 < "../${_patch}"
56 make install_prefix="${pkgdir}" install
57 install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
58 install -Dm 644 CHANGES README -t "${pkgdir}/usr/share/doc/${pkgname}"