1 # Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
2 # Contributor: Richard Murri <admin@richardmurri.com>
3 # Contributor: Michal Krenek <mikos@sg1.cz>
9 pkgdesc="Enterprise-class stacked cryptographic filesystem for Linux"
10 url="https://launchpad.net/ecryptfs"
12 makedepends=('intltool' 'gettext')
14 source=("https://launchpad.net/ecryptfs/trunk/${pkgver}/+download/${pkgname}_${pkgver}.orig.tar.gz"
15 "${pkgname}_${pkgver}.orig.tar.gz.sig::https://launchpad.net/ecryptfs/trunk/${pkgver}/+download/..-${pkgname}_${pkgver}.orig.tar.gz.asc"
16 "openssl-1.1.x.patch")
17 md5sums=('83513228984f671930752c3518cac6fd'
19 'bc69f5adcd397220bb8575252486c69f')
20 sha256sums=('112cb3e37e81a1ecd8e39516725dec0ce55c5f3df6284e0f4cc0f118750a987f'
22 '73d3689e51e57a03f8de66bfdb4a4c4fcc7f1c233895a7a576df6da7f64366d6')
23 validpgpkeys=('E2D9E1C5F9F5D59291F4607D95E64373F1529469')
26 cd ${pkgname}-${pkgver}
27 patch -Np0 -i "${srcdir}"/openssl-1.1.x.patch
31 cd ${pkgname}-${pkgver}
32 ./configure --prefix=/usr --with-pamdir=/usr/lib/security \
38 cd ${pkgname}-${pkgver}
39 make DESTDIR="${pkgdir}"/ rootsbindir='/usr/bin' install
40 chmod +s "${pkgdir}"/usr/bin/mount.ecryptfs_private