1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Ysblokje <ysblokje@gmail.com>
3 # Contributor: Mark Wagie <mark.wagie@tutanota.com>
8 pkgdesc='A daemon/lib combo that allows games to request a set of optimisations be temporarily applied to the host OS'
10 url=https://github.com/FeralInteractive/gamemode
23 checkdepends=(appstream)
28 _tag=4dc99dff76218718763a6b07fc1900fa6d1dafd9
29 source=(git+https://github.com/FeralInteractive/gamemode.git#tag=${_tag})
38 export CFLAGS+=' -Wno-implicit-function-declaration'
39 arch-meson gamemode build \
40 --libexecdir /usr/lib/gamemode \
41 -Dwith-examples=false \
42 -Dwith-pam-group=gamemode \
43 -Dwith-systemd-user-unit-dir=/usr/lib/systemd/user
44 meson compile -C build
52 DESTDIR="${pkgdir}" meson install -C build
53 install -Dm 644 gamemode/LICENSE.txt -t "${pkgdir}"/usr/share/licenses/gamemode/
56 # vim: set ts=4 sw=4 tw=0 et :