archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / gamemode / trunk / PKGBUILD
blobe26da93e6bd2f067b300a8d68dfc965d433f96a8
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Ysblokje <ysblokje@gmail.com>
3 # Contributor: Mark Wagie <mark.wagie@tutanota.com>
5 pkgname=gamemode
6 pkgver=1.7
7 pkgrel=1
8 pkgdesc='A daemon/lib combo that allows games to request a set of optimisations be temporarily applied to the host OS'
9 arch=(x86_64)
10 url=https://github.com/FeralInteractive/gamemode
11 license=(BSD)
12 depends=(
13   glibc
14   libdbus-1.so
15   libinih
16   libsystemd.so
17   polkit
19 makedepends=(
20   git
21   meson
23 checkdepends=(appstream)
24 provides=(
25   libgamemode.so
26   libgamemodeauto.so
28 _tag=4dc99dff76218718763a6b07fc1900fa6d1dafd9
29 source=(git+https://github.com/FeralInteractive/gamemode.git#tag=${_tag})
30 b2sums=(SKIP)
32 pkgver() {
33   cd gamemode
34   git describe --tags
37 build() {
38   export CFLAGS+=' -Wno-implicit-function-declaration'
39   arch-meson gamemode build \
40     --libexecdir /usr/lib/gamemode \
41     -Dwith-examples=false \
42     -Dwith-pam-group=gamemode \
43     -Dwith-systemd-user-unit-dir=/usr/lib/systemd/user
44   meson compile -C build
47 check() {
48   meson test -C build
51 package() {
52   DESTDIR="${pkgdir}" meson install -C build
53   install -Dm 644 gamemode/LICENSE.txt -t "${pkgdir}"/usr/share/licenses/gamemode/
56 # vim: set ts=4 sw=4 tw=0 et :