archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / geckodriver / repos / community-x86_64 / PKGBUILD
blob853753965c09c7f54292f2caeeff56dc983506bf
1 # Maintainer: Jelle van der Waa <jelle@archlinux.org>
2 # Contributor: kevku <kevku@gmx.com>
4 pkgname=geckodriver
5 pkgver=0.32.2
6 pkgrel=1
7 pkgdesc="Proxy for using W3C WebDriver-compatible clients to interact with Gecko-based browsers."
8 arch=("x86_64")
9 url="https://github.com/mozilla/geckodriver"
10 license=("MPL")
11 makedepends=("rust" "cargo" "gcc-libs")
12 source=($pkgname-$pkgver.tar.gz::https://github.com/mozilla/geckodriver/archive/refs/tags/v${pkgver}.tar.gz)
13 sha256sums=('f76e061b164e45413721439165949bf374ede71306292cf364bf88b196874fad')
14 validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
16 build() {
17   cd $pkgname-$pkgver
18   cargo build --bin geckodriver --release
21 package() {
22   cd $pkgname-$pkgver
23   install -Dm755 target/release/$pkgname "$pkgdir"/usr/bin/$pkgname
24   ln -sf /usr/bin/$pkgname "$pkgdir"/usr/bin/wires