archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / gpac / trunk / PKGBUILD
blobe05a47d88ae9c1c37fbd5b90e530af2c3e8a17f7
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Eric BĂ©langer <eric@archlinux.org>
4 pkgname=gpac
5 pkgver=2.2.1
6 pkgrel=1
7 epoch=1
8 pkgdesc='A multimedia framework based on the MPEG-4 Systems standard'
9 arch=(x86_64)
10 url=https://gpac.wp.imt.fr/
11 license=(LGPL)
12 depends=(
13   glibc
14   libnghttp2
15   openssl
16   xz
17   zlib
19 makedepends=(git)
20 optdepends=('python: python bindings')
21 provides=(libgpac.so)
22 _tag=b34e3851670f4398a4e2efcb86b30a8b07743212
23 source=(git+https://github.com/gpac/gpac.git#tag=${_tag})
24 b2sums=(SKIP)
26 pkgver() {
27   cd gpac
28   git describe --tags | sed 's/^v//'
31 build() {
32   export CFLAGS+=" -ffat-lto-objects"
33   export CXXFLAGS+=" -ffat-lto-objects"
34   cd gpac
35   ./configure \
36     --prefix=/usr \
37     --mandir=/usr/share/man \
38     --disable-oss-audio \
39     --disable-dvb4linux \
40     --disable-qjs \
41     --enable-pic
42   make
45 package() {
46   make DESTDIR="${pkgdir}" STRIP=true -C gpac install
47   make DESTDIR="${pkgdir}" STRIP=true -C gpac install-lib
50 # vim: ts=2 sw=2 et: