archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haruna / trunk / PKGBUILD
blob96195536f72cf933dd59a9800c61c2f5ec463b14
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: prg <prg _at_ xannode _dot_ com>
3 # Contributor: Nico <d3sox at protonmail dot com>
4 # Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
6 pkgname=haruna
7 pkgver=0.11.0
8 pkgrel=1
9 pkgdesc='Video player built with Qt/QML on top of libmpv'
10 arch=(x86_64)
11 url='https://apps.kde.org/haruna/'
12 license=(GPL3)
13 depends=(kfilemetadata kio mpv kirigami2)
14 makedepends=(extra-cmake-modules kdoctools)
15 optdepends=('yt-dlp: YouTube support')
16 source=(https://download.kde.org/stable/$pkgname/$pkgname-$pkgver.tar.xz{,.sig})
17 sha256sums=('668732316eba0622b5d193dd33e7ffec6f34348fb13597dbe90e72a830111914'
18             'SKIP')
19 validpgpkeys=(4E421C6554B89766DF9B7A37E12AB207C8755905) # George Florea Bănuș <georgefb899@gmail.com>
21 build() {
22   cmake -B build -S $pkgname-$pkgver
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build