1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=haskell-heapsize
7 pkgdesc="Determine the size of runtime data structures"
8 url="https://github.com/pepeiborra/heapsize.git"
11 depends=('ghc-libs' 'haskell-hashable' 'haskell-hashtables' 'haskell-primitive'
12 'haskell-unordered-containers')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('1e68f7c7a67e2565308e19505c61a378118ec5b24a9ebfbe669766dbd867686c')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
26 runhaskell Setup build $MAKEFLAGS
27 runhaskell Setup register --gen-script
28 runhaskell Setup unregister --gen-script
29 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
37 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
38 runhaskell Setup copy --destdir="$pkgdir"
39 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
40 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE